Accesos remotos va puerto AUX

 

1. Desde AUX de un router a Console de otro router (o switch):

 

Esto nos puede servir para tener gestin de un equipo remoto, an cuando por cambios en las configuraciones perdamos el control

y debamos reiniciarlo. Tambin para diagnosticar fallas de POST en un router o switch.

 

1.1 Configuracin

 

!

aaa authentication login default local (AAA habilitado con base de usuarios local)

aaa authorization exec default local

!

--resumido--

!

username ernesto privilege 15 secret 5 $1$483o$KlekdRbdcf11OVOVee.cs0 (base de usuarios local)

!

--resumido--

!

line aux 0

modem InOut (habilita el acceso en cuestin por cable rollover)

transport input all

stopbits 1

flowcontrol hardware

line vty 0 4 (no tiene mtodo de acceso, entonces por default usa la base de usuarios local)

transport input all

!

 

1.2 Verificacin

 

Router2600#sh line

Tty Line Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

0 0 CTY - - - - - 0 0 0/0 -

* 1 1 AUX 9600/9600 - inout - - - 2 0 3/0 -

* 194 194 VTY - - - - - 4 0 0/0 -

195 195 VTY - - - - - 0 0 0/0 -

196 196 VTY

 

1.3 Prueba de acceso remoto por consola

 

Router2600#telnet 192.168.0.1 2001 (2000 + nmero de AUX en show line)

Trying 192.168.0.1, 2001 ... Open

 

 

User Access Verification

 

Username: ernesto (usa la base de usuarios local por default)

Password: **********

 

Gateway> (estoy en el otro router pero por el puerto de consola)

 

1.4 Apago y enciendo el router 800 por ejemplo, y vemos en forma remota:

 

%#&$* (basura de la transmisin)

System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 2002 by cisco Systems, Inc.

C800/SOHO series (Board ID: 29-129) platform with 32768 Kbytes of main memory

 

program load complete, entry point: 0x80013000, size: 0x555034

Self decompressing the image : ###############################################################

##############################################################################################

---resumido---

*Mar 1 00:00:21.188: %SNMP-5-COLDSTART: SNMP agent on host Gateway is undergoing a cold start

*Mar 1 00:00:25.268: %SSH-5-ENABLED: SSH 1.5 has been enabled

Gateway>

Gateway> (ejecuto Shift + Ctrl + 6 y vuelvo al router 2600)

 

Router2600#

Router2600#who

Line User Host(s) Idle Location

1 aux 0 ernesto idle 00:00:04 192.168.0.1

*194 vty 0 ernesto 192.168.0.1 00:00:04 10.0.0.7

 

Interface User Mode Idle Peer Address

 

Router2600# (enter 2 veces y vuelvo al puerto de consola del 831)

 

[Resuming connection 1 to 192.168.0.1 ... ]

 

Gateway>

 

 

Cisco 2600

 

 

Cisco 831

 

 

Cable rollover (1-2-3-4-5-6-7-8 a 8-7-6-5-4-3-2-1)

 

 

 

2. Desde un PC con modem a un modem conectado en AUX, para acceder desde una ubicacin remota o bien

si hay perdida de control va TCP/IP. Debemos tener el modem conectado a la PSTN.

 

 

2.1 Sesin de Putty

 

 

 

at (comandos de control del modem, con este verificamos que el dispositivo responda)

 

Mas info: http://en.wikipedia.org/wiki/Hayes_command_set

 

at

 

OK

ati4 (verificamos modelo de modem)

 

HDAUDIO Soft Data Fax Modem with SmartCP

OK

at&v (verificamos configuracin del modem)

 

ACTIVE PROFILE:

E1 L1 M1 Q0 T V1 X4 &C1 &D2 &G0 &P1

S00:000 S01:000 S02:043 S03:013 S04:010 S05:008 S06:002 S07:090 S08:002

S10:254 S12:050 S29:010

 

STORED PROFILE 0:

E1 L1 M1 Q0 T V1 X4 &C1 &D2 &G0 &P1

S00:000 S02:043 S06:002 S07:090 S08:002 S10:014 S12:050 S29:010

 

OK

 

atdt1 (discado por tonos al interno nmero 1 de la PBX)

 

CONNECT (conectado pero con basura)

##xJ`tx:(msK!9==efB-s-eAwZN⼡oVL?#R5ta)0}~agrs@o

HyϲavJ峱X,Zt\ű_n@/HMv^(|8ios"M*R뢺Ȳ0VJ%s:,y

Uo_뫤 %:0!\INQ,=84K}L=cebY\7[kvq1%jJGͮsڤ;߾

!^EuNYJ K"APT8 n@x" c$Au~Z$Kf/G|fbJ

 

Cambios en la configuracin del router

 

Router_1800#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router_1800(config)#line aux 0

Router_1800(config-line)#speed 9600 (velocidad del puerto console 0)

Router_1800(config-line)#^Z

Router_1800#

 

at (nos conectamos nuevamente)

 

OK

atdt1

 

CONNECT

 

 

User Access Verification

 

Password: (cisco)

Router_1800>

Router_1800>enable

Password: (class)

Router_1800#sh line

Tty Line Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

* 0 0 CTY - - - - - 0 0 0/0 -

* 1 1 AUX 9600/9600 - inout - - - p 8 0</0 0 -

194 194 VTY - - - - - 0 0 0/0 -

195 195 VTY - - - - - 0 0 0/0 -

196 196 VTY - - - - - 0 0 0/0 -

197 197 VTY - - - - - 0 0 0/0 -

198 198 VTY - - - - - 0 0 0/0 -

 

Line(s) not in async mode -or- with no hardware support:

2-193

Router_1800#sh runn (algunos parmetros estn resumidos)

Building configuration...

 

Current configuration : 1084 bytes

!

version 12.4

no service password-encryption

!

hostname Router_1800

!

!

enable secret 5 $1$bFar$lxCPjsuqg

!

!

!

interface FastEthernet0/0

ip address 10.0.1.1 255.255.255.0

!

interface FastEthernet0/1

ip address 200.0.0.1 255.255.255.252

!

!

!

ip route 0.0.0.0 0.0.0.0 200.0.0.2

!

line con 0

password cisco

login

line aux 0

password cisco

login

modem InOut

transport input telnet

line vty 0 4

login

!

end

 

Router_1800# +++ (tomamos control del modem)

OK

ath (cortamos la comunicacin)

OK

 

 

Nota: La PBX Nor-K 142 es gentileza de Mariano Andrs, alumno de CCNA 2.

El cable es el negro con conector DB-25 que se provee junto con algunos routers.

 

 

Foto: Observamos que no hay otra conexin disponible para acceder al router.

 

 

 

(2012) Smoking chala with uncle Ernest

Rosario, Argentina